読者です 読者をやめる 読者になる 読者になる

雑記 日記帳  中古PCにジェンツーペンギン。part4

中古PCにジェンツーペンギン。part4

何故か途中まで書いていた物が消されたようで見つからないので、思い出しながらの

2度目の書き込みで、これは非常に疲労するパターンです。

信じられ無い事にサブPCのジェンツーペンギンをcopyした物が、この中古PCで起動しました。ちゃんとしたMATEでした。

多分起動率は1/20以下なのではとは思いますが、やり方はマルチブートメニューのリカバリモードの方を選択して、いじっていたら偶然にもジェンツーペンギンのセッション選択画面が表示でパスワードを打ち込んだらMATEが起動しました。

この中古PCではCtrl Alt F6キー でCUI画面にする事が出来ません、emacsのような物なら表示出来ますが、使用方法を知らないのでNG。

追記

中古PCでサブPCのジェンツーペンギンをcopyした物を起動させる方法

マルチブートメニューのリカバリモードの方を選択して

e > Tabキー > Ctrl x > ここで間髪を入れずに Ctrl Alt F6キー を連打

以上でジェンツーペンギンのセッション選択画面が表示でした。

再現性が有るのか不明ですが。

と言う事はジェンツーペンギンではグラボNVIDIA GT240 LP 1GBはlegacy cardでは無いと言う事のようです。

追記終わり

 

2015-05-27 追記

同様な方法でサブPCからcopyした、CLDX14.12.1が起動しました。

CLDX14.12.1はリカバリモードの方を選択して、だけでOKで起動しました。

これはマトモなMATEなのでこの方が使用しやすいのですが、

何故CLDX14.12.1にMATEをインストールする事が出来なく成ったのかが気に成ります。

ArchとSabayanはダメでした。

2015-05-27 追記終わり

 

起動率をUPさせる為に端末で

# emerge --quiet-build --emptytree @world

をしましたが、端末の表示はエラー。

 

# emerge --ask --changed-use --deep @world

をしましたが、端末の表示はエラー。

 

# emerge --quiet-build --update --newuse --deep @world
これはまだ試していません。その後試したようです。
端末の表示はmanかGentoo Handbookを読めでした。

# emerge -uDN world
をしましたが、端末の表示はエラー。

* IMPORTANT: 13 news items need reading for repository 'gentoo'.
* Use eselect news read to view new items.

Calculating dependencies... done!
[ebuild U ] sys-kernel/linux-headers-3.18 [3.13]
[ebuild N ] sys-apps/gentoo-functions-0.8
[ebuild U ] app-arch/xz-utils-5.0.8 [5.0.5-r1]
[ebuild U ] virtual/libintl-0-r1 [0] ABI_X86="(64%*) -32% (-x32)"
[ebuild R ] dev-lang/python-exec-2.0.1-r1 PYTHON_TARGETS="(pypy3%*) (python3_4*) (-python3_2%*)"
[ebuild U ] media-libs/libpng-1.6.16 [1.6.10]
[ebuild U ] virtual/libiconv-0-r2 [0-r1]
[ebuild U ] dev-libs/expat-2.1.0-r4 [2.1.0-r3]

        大幅に中略

[ebuild U ] dev-perl/File-BaseDir-0.30.0-r1 [0.30.0]
[ebuild U ] app-text/po4a-0.45-r1 [0.42]
[ebuild U ] dev-perl/File-DesktopEntry-0.40.0-r1 [0.40.0]
[ebuild U ] app-arch/dpkg-1.17.25 [1.17.10] USE="(-selinux)"
[ebuild U ] dev-perl/File-MimeInfo-0.210.0 [0.170.0]
[ebuild U ] dev-util/debhelper-9.20150101 [9.20140228]
[ebuild U ] app-arch/alien-8.90 [8.89]

!!! Multiple package instances within a single package slot have been pulled
!!! into the dependency graph, resulting in a slot conflict:

sys-libs/readline:0

(sys-libs/readline-6.3_p8-r2:0/0::gentoo, ebuild scheduled for merge) pulled in by
>=sys-libs/readline-6.3 required by (app-shells/bash-4.3_p33-r2:0/0::gentoo, ebuild scheduled for merge)
^^ ^^^

(sys-libs/readline-6.2_p5-r1:0/0::gentoo, installed) pulled in by
=sys-libs/readline-6.2* required by (media-video/xine-ui-0.99.7:0/0::gentoo, installed)
^ ^^^^

dev-lang/perl:0

(dev-lang/perl-5.20.2:0/5.20::gentoo, ebuild scheduled for merge) pulled in by
=dev-lang/perl-5.20* required by (virtual/perl-Time-Local-1.230.0-r1:0/0::gentoo, installed)
^ ^^^^^
(and 28 more with the same problem)

(dev-lang/perl-5.16.3:0/5.16::gentoo, installed) pulled in by
dev-lang/perl:0/5.16=[-build(-)] required by (dev-perl/Net-HTTP-6.60.0:0/0::gentoo, installed)
^^^^^^^^
(and 9 more with the same problem)


It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in
the dependencies of two different packages, then those packages can
not be installed simultaneously. You may want to try a larger value of
the --backtrack option, such as --backtrack=30, in order to see if
that will solve this conflict automatically.

For more information, see MASKED PACKAGES section in the emerge man
page or refer to the Gentoo Handbook.


The following USE changes are necessary to proceed:
(see "package.use" in the portage(5) man page for more details)
# required by media-sound/exaile-0.3.2.0::gentoo
# required by @selected
# required by @world (argument)
>=dev-lang/python-2.7.9-r1:2.7 sqlite
# required by virtual/ffmpeg-9-r1::gentoo
# required by media-video/mplayer2-2.0_p20130428-r1::gentoo
# required by @selected
# required by @world (argument)
>=media-video/ffmpeg-2.2.14 threads
# required by x11-libs/libX11-1.6.2::gentoo
# required by x11-apps/xkbcomp-1.3.0::gentoo
# required by x11-libs/libxklavier-5.3::gentoo
# required by mate-base/mate-control-center-1.8.3::gentoo
# required by mate-base/mate-1.8.0::gentoo[base]
# required by @selected
# required by @world (argument)
>=x11-proto/xextproto-7.3.0 abi_x86_32
# required by x11-drivers/nvidia-drivers-349.16::gentoo[X,multilib]
# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
>=x11-libs/libX11-1.6.2 abi_x86_32
# required by media-video/minitube-2.0::gentoo
# required by @selected
# required by @world (argument)
>=dev-qt/qtgui-4.8.6-r4 gtkstyle
# required by x11-libs/libX11-1.6.2::gentoo
# required by x11-apps/xkbcomp-1.3.0::gentoo
# required by x11-libs/libxklavier-5.3::gentoo
# required by mate-base/mate-control-center-1.8.3::gentoo
# required by mate-base/mate-1.8.0::gentoo[base]
# required by @selected
# required by @world (argument)
>=x11-proto/kbproto-1.0.6-r1 abi_x86_32
# required by x11-libs/libX11-1.6.2::gentoo
# required by x11-apps/xkbcomp-1.3.0::gentoo
# required by x11-libs/libxklavier-5.3::gentoo
# required by mate-base/mate-control-center-1.8.3::gentoo
# required by mate-base/mate-1.8.0::gentoo[base]
# required by @selected
# required by @world (argument)
>=x11-proto/xproto-7.0.27 abi_x86_32
# required by x11-libs/libX11-1.6.2::gentoo
# required by x11-apps/xkbcomp-1.3.0::gentoo
# required by x11-libs/libxklavier-5.3::gentoo
# required by mate-base/mate-control-center-1.8.3::gentoo
# required by mate-base/mate-1.8.0::gentoo[base]
# required by @selected
# required by @world (argument)
>=x11-proto/inputproto-2.3.1 abi_x86_32
# required by x11-libs/libX11-1.6.2::gentoo
# required by x11-apps/xkbcomp-1.3.0::gentoo
# required by x11-libs/libxklavier-5.3::gentoo
# required by mate-base/mate-control-center-1.8.3::gentoo
# required by mate-base/mate-1.8.0::gentoo[base]
# required by @selected
# required by @world (argument)
>=x11-proto/xf86bigfontproto-1.2.0-r1 abi_x86_32
# required by www-client/chromium-43.0.2357.65::gentoo
# required by @selected
# required by @world (argument)
>=media-libs/harfbuzz-0.9.38 icu
# required by x11-drivers/nvidia-drivers-349.16::gentoo[X,multilib]
# required by x11-base/xorg-drivers-1.16::gentoo[video_cards_nvidia]
# required by x11-base/xorg-server-1.16.4::gentoo[xorg]
# required by x11-drivers/xf86-input-keyboard-1.8.0::gentoo
>=x11-libs/libXext-1.3.3 abi_x86_32
# required by www-client/chromium-43.0.2357.65::gentoo
# required by @selected
# required by @world (argument)
>=dev-libs/libxml2-2.9.2-r1 icu
# required by x11-libs/libX11-1.6.2::gentoo
# required by x11-apps/xkbcomp-1.3.0::gentoo
# required by x11-libs/libxklavier-5.3::gentoo
# required by mate-base/mate-control-center-1.8.3::gentoo
# required by mate-base/mate-1.8.0::gentoo[base]
# required by @selected
# required by @world (argument)
>=x11-libs/libxcb-1.11-r1 abi_x86_32

Use --autounmask-write to write changes to config files (honoring
CONFIG_PROTECT). Carefully examine the list of proposed changes,
paying special attention to mask or keyword changes that may expose
experimental or unstable packages.

!!! The following installed packages are masked:
- sci-geosciences/googleearth-7.1.2.2041::gentoo (masked by: package.mask, googleearth license(s))
/usr/portage/profiles/package.mask:
# Julian Ospald <hasufell@gentoo.org> (21 Jul 2013)
# Mask all unfetchable versions and those with tons of random
# bugs and segfaults (all). Don't ask for a version bump unless
# there is a working release.

A copy of the 'googleearth' license is located at '/usr/portage/licenses/googleearth'.

For more information, see the MASKED PACKAGES section in the emerge
man page or refer to the Gentoo Handbook.


emerge: there are no ebuilds built with USE flags to satisfy "dev-libs/libxml2:=[icu]".
!!! One of the following packages is required to complete your request:
- dev-libs/libxml2-2.9.2::gentoo (Change USE: +icu)
(dependency required by "www-client/chromium-43.0.2357.65::gentoo" [ebuild])
(dependency required by "@selected" [set])
(dependency required by "@world" [argument])
Gentoo Linux hoge #

エラー表示が対策を建てる時に対策のやり方が分からない物に変わっていました。
以前は/etc/portage/package.useはファイルでしたが、昨日、怪しげなCUIにまで
にしか出来なかった物ですがフォルダーに成っていました。