読者です 読者をやめる 読者になる 読者になる

雑記 日記帳  構想として 今のジェンツーペンギン 8月 partXX 中古PC 実機 その2

構想として 今のジェンツーペンギン 8月 partXX 中古PC 実機 その2

書き込んで、実際はUbuntu10.04を起動でコピペで保存で再び

# emerge --quiet-build xorg-server 
ここで大ミスを発見rebootして再起動してgentooを立ち上げていなかったようで
マルチブートメニューにgentooの欄が無い。
と思ったが、見るとrebootして再起動してgentooを立ち上げているような感じ。
Ubuntu10.04が起点ではダメなのかも知れませんのでここで起点をMint17にしてみます。
あまり期待は持てませんが。
端末マルチブートメニューにgentooの欄が表示です。
教訓、今のジェンツーペンギンのマルチブートメニューを表示させようと思うなら
起点がUbuntu10.04で
はダメで有る。
と思ったが、再起動でジェンツーペンギンのマルチブートメニューの欄が無い。
sda26の次がsda28でsda27が表示されていない。
これでダメだったらtomboyがダメでもV-BOXのやり方で試して見る。
emerge --syncが出来るのは1日に1回だけなので、日を見て作業する事にする。
これも実機で行けると言う保証は何処にも無いのですが。
ここで起点をKLUE MATE 64bitにしてやってみる。
端末ではsda27は認識で表示ですが、再起動でどうなのか、これからやってみます。
再起動でジェンツーペンギンのマルチブートメニューの欄が無い。
これはがっかりな結果。
USBメモリをPCに挿してHDDのmanjaroを起動で起点をmanjaroにして
試してみる事にします。
実機もやれば、やるだけ段々と悪化の傾向のような感じ。
無いならば、手書きで書き込めばどうなのか?起点のOSのgrub.cfgですが。
後で試して見ます。例の1回はこのkernelで起動していなければNGの表示が出るのか?
これは/bootが別パテだったので/のbootフォルダにcopyしてfstab
も書き換える事にしようか?そうしないと起点のOSのgrub.cfgを書くのが大変。
manjaroでマルチブートメニューを作る為の作業をするとパテが多いいので
1時間位は掛かる。
またHDDが壊れそうな気がする。
再起動してみます。
再起動でジェンツーペンギンのマルチブートメニューの欄が無い。
ハンドメイドで作った。
起動しました。おめでとうございます。
先が思いやられます。でここで
# emerge --quiet-build xorg-server 
USE="-static-libs"
USE="dri -doc {-test}"
ABI_X86="(64) -32 (-x32)"
USE="(-selinux)"
ABI_X86="32*"
USE="-doc"
USE="bzip2 ipv6 truetype -doc -static-libs"
INPUT_DEVICES="evdev keyboard mouse -acecad -aiptec -elographics -fpit -hyperpen -joystic (-libinput) -mutouch -penmount -synaptics -tslib -vmmouse -void -wacom"
VIDEO_CARDS="nvidia -apm -ast chips -cirrus -dummy -epson -fbdev -fglrx (-freedreno) (-geode) -glint -i128 (-740) -intel -mach64 -mga -modesetting -neomagic -nouveau -nv (-omap) (-omapfb) -qxl -r128 -radeon -radeonsi -rendition -s3 -s3virge -savage -siliconmotion -sisusb (-sunbw2) (-suncg14) (-suncg3) (-suncg6) (-sunffb) (-sunleo) (-suntcx) -tdfx -tga -trident -tseng -v41 -vesa -via -virtualbox -vmware (-voodoo)"
USE="-firmware"
USE="kmod udev zlib -dns -static-libs"
USE="minimal"
USE="glamor ipv6 nptl suid udev xorg -dmx -doc -kdrive -minimal (-selinux) -static-libs -systemd -tslib -unwind -wayland -xnest -xvfb"
USE="X acpi gtk2 multilib tools -gtk3 -pax_kernel -uvm"
"package.use"     g-custom
>=x11-libs/libXau-1.0.8 abi_x86_32
>=x11-proto/kbproto-1.0.6-r1 abi_x86_32
>=x11-libs/libXdmcp-1.1.1-r1 abi_x86_32
>=x11-libs/libpthread-stubs-0.3-r1 abi_x86_32
>=x11-proto/xf86bigfontproto-1.2.0 abi_x86_32
>=x11-proto/xproto-7.0.27 abi_x86_32
>=x11-proto/inputproto-2.3.1 abi_x86_32
>=x11-proto/xextproto-7.3.0 abi_x86_32
>=x11-libs/libXext-1.3.3 abi_x86_32
>=x11-proto/xcb-proto-1.11 abi_x86_32
>=x11-libs/libX11-1.6.2 abi_x86_32
>=x11-libs/libxcb-1.11-r1 abi_x86_32
---------------------------------------------------
今回新たに
"package.use"
>=dev-libs/libpthread-stubs-0.3-r1 abi_x86_32
# nano /etc/portage/package.use/g-custom
>=
dev-libs/libpthread-stubs-0.3-r1 abi_x86_32

ソース15

hanepjiv                2014年11月22日土曜日
Gentoo Linux / gentooのアップデート   変更 2015-04-27
http://hanepjiv.blogspot.jp/2014/11/gentoo-linux-3-gentoo.html

(貼り付け開始)下記の #は//  $は# で使用だと思う。

    # maskやuseで競合が起こったと仮定

    $ emerge --autounmask-write -vDNu world 
    $ dispatch-conf
    $ emerge -pvDNu world
    # ↑ 設定を自動更新して再度確認
    # これでも競合が解消されなければ手作業でmaskやuseを調整

(貼り付け終了)

ソース15を3回位やって

# emerge --quiet-build xorg-server 
この間の作業は省略で、実機でLXDE、Xfce4、MATEをインストール。
ibus、mozc、smplayer、hardinfo、gparted、leafpad、clementine、radiotray、
file-roller、gksu、はemerge出来て機能しているようです。
が、tomboyが・・・・・

$ sudo su 

# emerge -avt tomboy 

 

Invalid '-' operator in non-incremental variable 'VIDEO_CARDS': '-vmware'
... done!
[ebuild N ] app-misc/tomboy-1.14.1::gentoo USE="-eds {-test}" 0 KiB
[ebuild N ] dev-dotnet/gconf-sharp-2.24.2:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/gnome-sharp-2.24.2:2::gentoo USE="-debug" 0 KiB
[ebuild N ] gnome-base/libgnomeui-2.24.5-r1::gentoo USE="{-test}" 0 KiB
[ebuild N ] gnome-base/libbonoboui-2.24.5-r1::gentoo USE="-examples {-test}" 0 KiB
[ebuild N ] dev-dotnet/gnomevfs-sharp-2.24.2:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/glade-sharp-2.12.10:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/mono-addins-0.6.2::gentoo USE="gtk" 0 KiB
[nomerge ] dev-dotnet/gnome-sharp-2.24.2:2::gentoo USE="-debug"
[ebuild N ] dev-dotnet/art-sharp-2.24.2:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/gtk-sharp-2.12.10:2::gentoo USE="-debug" 0 KiB
[ebuild N ] dev-dotnet/gdk-sharp-2.12.10:2::gentoo USE="-debug" 0 KiB

Total: 11 packages (11 new), Size of downloads: 0 KiB

Would you like to merge these packages? [Yes/No] yes

>>> Verifying ebuild manifests
Invalid '-' operator in non-incremental variable 'ABI_X86': '-32'
Invalid '-' operator in non-incremental variable 'INPUT_DEVICES': '-acecad'

 

PangoAttrEmbossColor.custom(21,49): error CS0246: The type or namespace name `Pango' could not be found. Are you missing a using directive or an assembly reference?
PangoAttrEmbossColor.custom(26,71): error CS0246: The type or namespace name `Pango' could not be found. Are you missing a using directive or an assembly reference?
PangoAttrEmbossed.custom(37,24): error CS0246: The type or namespace name `Pango' could not be found. Are you missing a using directive or an assembly reference?
PangoAttrEmbossed.custom(43,49): error CS0246: The type or namespace name `Pango' could not be found. Are you missing a using directive or an assembly reference?
PangoAttrEmbossed.custom(48,68): error CS0246: The type or namespace name `Pango' could not be found. Are you missing a using directive or an assembly reference?
PangoAttrStipple.custom(39,24): error CS0246: The type or namespace name `Pango' could not be found. Are you missing a using directive or an assembly reference?
PangoAttrStipple.custom(51,49): error CS0246: The type or namespace name `Pango' could not be found. Are you missing a using directive or an assembly reference?
PangoAttrStipple.custom(56,67): error CS0246: The type or namespace name `Pango' could not be found. Are you missing a using directive or an assembly reference?
generated/PangoRenderer.cs(57,46): warning CS0109: The member `Gdk.PangoRenderer.GType' does not hide an inherited member. The new keyword is not required
Compilation failed: 8 error(s), 2 warnings
Makefile:681: recipe for target 'gdk-sharp.dll' failed
make[1]: *** [gdk-sharp.dll] Error 1
make[1]: Leaving directory '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/work/gtk-sharp-2.12.10/gdk'
Makefile:378: recipe for target 'all-recursive' failed
make: *** [all-recursive] Error 1
emake failed
* ERROR: dev-dotnet/gdk-sharp-2.12.10::gentoo failed (compile phase):
* emake failed
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 3065: Called gtk-sharp-module_src_compile
* environment, line 2238: Called die
* The specific snippet of code:
* emake CSC=/usr/bin/mcs || die "emake failed"
*
* If you need support, post the output of `emerge --info '=dev-dotnet/gdk-sharp-2.12.10::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-dotnet/gdk-sharp-2.12.10::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/temp/environment'.
* Working directory: '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/work/gtk-sharp-2.12.10/gdk'
* S: '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/work/gtk-sharp-2.12.10'

>>> Failed to emerge dev-dotnet/gdk-sharp-2.12.10, Log file:

>>> '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/temp/build.log'

* Messages for package dev-dotnet/gdk-sharp-2.12.10:

* ERROR: dev-dotnet/gdk-sharp-2.12.10::gentoo failed (compile phase):
* emake failed
*
* Call stack:
* ebuild.sh, line 93: Called src_compile
* environment, line 3065: Called gtk-sharp-module_src_compile
* environment, line 2238: Called die
* The specific snippet of code:
* emake CSC=/usr/bin/mcs || die "emake failed"
*
* If you need support, post the output of `emerge --info '=dev-dotnet/gdk-sharp-2.12.10::gentoo'`,
* the complete build log and the output of `emerge -pqv '=dev-dotnet/gdk-sharp-2.12.10::gentoo'`.
* The complete build log is located at '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/temp/environment'.
* Working directory: '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/work/gtk-sharp-2.12.10/gdk'
* S: '/var/tmp/portage/dev-dotnet/gdk-sharp-2.12.10/work/gtk-sharp-2.12.10'
Invalid '-' operator in non-incremental variable 'ABI_X86': '-32'
Invalid '-' operator in non-incremental variable 'INPUT_DEVICES': '-acecad'