読者です 読者をやめる 読者になる 読者になる

雑記 日記帳 中古PC 実機 SSD Mint18  MATE  64bit  part1

中古PC 実機 SSD Mint18  MATE  64bit  part1

linuxmint-18-mate-64bit.iso  1.8 GB (1781137408 バイト)

2016年06月30日 22時10分13秒 に落とし終えた.isoをUnetbootinUSBメモリに入れてSSDのsda3にインストール。

sda1はKona3.0 jack 64bit

sda2はKona3.0 jack 64bit  これは多分sda1をgpartedでcopyで例のワンパターンで作った物。

sda4は拡張領域。

sda5はKorora23 GNOME3でインストールでCinnamon追加でCinnamonで使用。

swapは作っていません。

2016-07-01 追記開始

ExaileのradioがMP3のみOKのような感じ、AACはNG。

何のコーデックが不足なのか不明。

 2016-07-06 追記開始

 これは gstreamer0.10-plugins-bad  と(badはMultiverseの方をインストしていた

     のですが、これをUbuntu 15.10 Ubuntu Universe:を上書きインストールす      る)

     gstreamer0.10-plugins-ugly  が不足の為(uglyはインストしていた)

     ubu15.10用のUbuntu Universe:の物を落として行けたような雰囲気

     Ubuntu Multiverse:ではExaileのradioがMP3ならOKでしたが

     他の物ではNGでした。 もうすぐサポ切れですが、何か?

 2016-07-06 追記終了

ubuntu-restrected-extrasはsynapticでインストールしたのに。

コーデックはubu15.10用を使用の物が有りでExaile本体はubu14.04用ですが。

 

2016-07-01 追記開始-1

Ubuntu 15.10  Ubuntu Multiverse:

gstreamer0.10-plugins-bad-multiverse_0.10.21-1ubuntu3_amd64.deb     を

インストールしていたのですが、これを

Ubuntu 15.10 Ubuntu Universe:

gstreamer0.10-plugins-bad_0.10.23-8.1ubuntu3_amd64.deb   を上書きインストールでクリア出来た感じ これをインストールする為に

# dpkg -i gstreamer0.10-plugins-bad_0.10.23-8.1ubuntu3_amd64.deb
以前に未選択のパッケージ gstreamer0.10-plugins-bad:amd64 を選択しています。
(データベースを読み込んでいます ... 現在 264885 個のファイルとディレクトリがインストールされています。)
gstreamer0.10-plugins-bad_0.10.23-8.1ubuntu3_amd64.deb を展開する準備をしています ...
gstreamer0.10-plugins-bad:amd64 (0.10.23-8.1ubuntu3) を展開しています...
dpkg: 依存関係の問題により gstreamer0.10-plugins-bad:amd64 の設定ができません:
gstreamer0.10-plugins-bad:amd64 は以下に依存 (depends) します: libcdaudio1 (>= 0.99.12p2) ...しかし:
パッケージ libcdaudio1 はまだインストールされていません。
gstreamer0.10-plugins-bad:amd64 は以下に依存 (depends) します: libgstreamer-plugins-bad0.10-0 (= 0.10.23-8.1ubuntu3) ...しかし:
パッケージ libgstreamer-plugins-bad0.10-0 はまだインストールされていません。
gstreamer0.10-plugins-bad:amd64 は以下に依存 (depends) します: libslv2-9 (>= 0.6.4-1~) ...しかし:
パッケージ libslv2-9 はまだインストールされていません。
gstreamer0.10-plugins-bad:amd64 は以下に依存 (depends) します: libsoundtouch0 (>= 1.8.0) ...しかし:
パッケージ libsoundtouch0 はまだインストールされていません。
gstreamer0.10-plugins-bad:amd64 は以下に依存 (depends) します: libvpx2 (>= 1.4.0) ...しかし
dpkg: パッケージ gstreamer0.10-plugins-bad:amd64 の処理中にエラーが発生しました (--install):
依存関係の問題 - 設定を見送ります
libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) のトリガを処理しています ...
libglib2.0-0:i386 (2.48.1-1~ubuntu16.04.1) のトリガを処理しています ...
処理中にエラーが発生しました:
gstreamer0.10-plugins-bad:amd64
hoge #

なのでsynapticに有る物はsynapticでインストール、無い物は.debを落としてインストール

上記で赤色がsynapticでインストールした物。

下記が落としたubu15.10用の.deb

libsoundtouch0_1.9.0-1_amd64.deb

libvpx2_1.4.0-4_amd64.deb 

libgstreamer-plugins-bad0.10-0_0.10.23-8.1ubuntu3_amd64.deb 

gstreamer0.10-plugins-bad_0.10.23-8.1ubuntu3_amd64.deb

********************************************************************

Mint18はUbuntu16.04とは結構違うような感じ、ubu16.04が出て2ケ月と1週間以上経っているので、この間に変化したとも考えられる。

Mint17.xをdist-upgradeでMint18にした方が正解なのか?

###########の下側が追加した物、一番最下段は追加で作業で終わって###を付加した。

/etc/apt/sources.list

---------------------------------

#deb cdrom:[Linux Mint 18 _Sarah_ - Release amd64 20160628]/ xenial contrib main non-free      <ーーーここはデフォで#付きでした。

##############################################################


deb http://archive.getdeb.net/ubuntu/ xenial-getdeb apps <ーーこれはaqualungインストール用で追加、まず最初にrepository GPG keyをgetする必要有り。

Install the repository GPG key:
$ wget -q -O- http://archive.getdeb.net/getdeb-archive.key | sudo apt-key add -

$ sudo leafpad /etc/apt/sources.list  で最下段に下記追加
deb http://archive.getdeb.net/ubuntu/ xenial-getdeb apps
で保存でleafpadを終了
Update the package index:
$ sudo apt-get update
Install aqualung deb package:
$ sudo apt-get install aqualung

ソース
pgks Linux
aqualung_1.0-1~getdeb2~wily_amd64.deb Ubuntu 16.04 LTS Download
https://pkgs.org/ubuntu-16.04/getdeb-apps-amd64/aqualung_1.0-1~getdeb2~wily_amd64.deb.html

 

deb http://archive.ubuntu.com/ubuntu/ xenial-proposed universe

deb http://archive.ubuntu.com/ubuntu/ xenial-proposed main

 

####deb http://jp.archive.ubuntu.com/ubuntu trusty main

--------------------------------------------------------

$ sudo su
# dpkg -i libvpx2_1.4.0-4_amd64.deb
以前に未選択のパッケージ libvpx2:amd64 を選択しています。
(データベースを読み込んでいます ... 現在 264906 個のファイルとディレクトリがインストールされています。)
libvpx2_1.4.0-4_amd64.deb を展開する準備をしています ...
libvpx2:amd64 (1.4.0-4) を展開しています...
libvpx2:amd64 (1.4.0-4) を設定しています ...
libc-bin (2.23-0ubuntu3) のトリガを処理しています ...
# dpkg -i libgstreamer-plugins-bad0.10-0_0.10.23-8.1ubuntu3_amd64.deb
以前に未選択のパッケージ libgstreamer-plugins-bad0.10-0:amd64 を選択しています。
(データベースを読み込んでいます ... 現在 264914 個のファイルとディレクトリがインストールされています。)
libgstreamer-plugins-bad0.10-0_0.10.23-8.1ubuntu3_amd64.deb を展開する準備をしています ...
libgstreamer-plugins-bad0.10-0:amd64 (0.10.23-8.1ubuntu3) を展開しています...
libgstreamer-plugins-bad0.10-0:amd64 (0.10.23-8.1ubuntu3) を設定しています ...
libc-bin (2.23-0ubuntu3) のトリガを処理しています ...
# dpkg -i gstreamer0.10-plugins-bad_0.10.23-8.1ubuntu3_amd64.deb
以前に未選択のパッケージ gstreamer0.10-plugins-bad:amd64 を選択しています。
(データベースを読み込んでいます ... 現在 264927 個のファイルとディレクトリがインストールされています。)
gstreamer0.10-plugins-bad_0.10.23-8.1ubuntu3_amd64.deb を展開する準備をしています ...
gstreamer0.10-plugins-bad:amd64 (0.10.23-8.1ubuntu3) を展開しています...
gstreamer0.10-plugins-bad:amd64 (0.10.23-8.1ubuntu3) を設定しています ...
libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) のトリガを処理しています ...
libglib2.0-0:i386 (2.48.1-1~ubuntu16.04.1) のトリガを処理しています ...
hoge # 

2016-07-01 追記終了-1

 

2016-07-03 追記開始 KLUE2.0 jack 64bitですが

root@ # dpkg -i gstreamer0.10-plugins-bad_0.10.23-8.1ubuntu3_amd64.deb
以前に未選択のパッケージ gstreamer0.10-plugins-bad:amd64 を選択しています。
(データベースを読み込んでいます ... 現在 383916 個のファイルとディレクトリがインストールされています。)
gstreamer0.10-plugins-bad_0.10.23-8.1ubuntu3_amd64.deb を展開する準備をしています ...
gstreamer0.10-plugins-bad:amd64 (0.10.23-8.1ubuntu3) を展開しています...
dpkg: 依存関係の問題により gstreamer0.10-plugins-bad:amd64 の設定ができません:
gstreamer0.10-plugins-bad:amd64 は以下に依存 (depends) します: libgstreamer-plugins-bad0.10-0 (= 0.10.23-8.1ubuntu3) ...しかし:
パッケージ libgstreamer-plugins-bad0.10-0 はまだインストールされていません。

dpkg: パッケージ gstreamer0.10-plugins-bad:amd64 の処理中にエラーが発生しました (--install):
依存関係の問題 - 設定を見送ります
libglib2.0-0:i386 (2.48.1-1~ubuntu16.04.1) のトリガを処理しています ...
libglib2.0-0:amd64 (2.48.1-1~ubuntu16.04.1) のトリガを処理しています ...
処理中にエラーが発生しました:
gstreamer0.10-plugins-bad:amd64
root@ #

2016-07-03 追記終了 KLUE2.0 jack 64bitですが

 

下記は以前書き込んだような気がしますが探し難いので

で、RT-kernel 4.6.2、qjackctl追加で

googleearthの起動率が0%でsynapticで完全削除した。

その後synapticで調べると既にia32-libsがインストール済みでしたので

昔落としたgoogleearth-7.1.1-deb 64bit用でインストールで起動率100%、おめでとうございます。

Mint18 64bitにはia32-libsが有る。 ia32-libs_2016.02.18_amd64.deb

738 名前:login:Penguin [sage]: 2016/05/29(日) 10:45:51.25 id:xFpfBVzQO (7)
[/etc/asound.confの内容]
# convert alsa API over jack API
# use it with
# % aplay foo.wav

# use this as default
pcm.!default {
type plug
slave { pcm "jack" }
}

# pcm type jack
pcm.jack {
type jack
playback_ports {
0 system:playback_1
1 system:playback_2
}
capture_ports {
0 system:capture_1
1 system:capture_2
}
}

konaが使ってるものとちょっとだけ違うが意味は同じもの
これだけでjack稼働中でもalsaから音が出るようになる


808 名前:login:Penguin [sage]: 2016/06/04(土) 05:55:07.06 ID:8k+UnobDk (16)
冗談のような名前のbaka-mplayerは初めてきいたがインストールしてみたら
mpvを再生エンジンとして使うプレイヤーだった(smplayerと同じ)。
それならmpvのデフォルト出力をjackへ変更する設定をすればよい。
~/.config/mpv/configというファイルを作成してao=jackと記述する。
この設定でklue 2.0 jackでもmpvに--ao=jackオプションを付けなくていい


821 名前:login:Penguin [sage]: 2016/06/04(土) 12:16:35.33 ID:8k+UnobDk (16)
baka-mplayerには設定ファイルがあることがわかった。
そこでao(audio output)を指定できる。
~/.config/baka-mplayer.ini
[内容]
{
"autoFit": 100,
"debug": false,
"gestures": true,
"hideAllControls": false,
"hidePopup": false,
"input": {
},
"lang": "auto",
"maxRecent": 5,
"mpv": {
"ao": "jack",
"msg-level": "status",
"screenshot-directory": ".",
"screenshot-format": "",
"screenshot-template": "screenshot%#04n",
"speed": 1,
"vo": "",
"volume": 100
},
(略)
}

「"ao": "jack"」 が付け加えたものだ。
初期状態ではこの記述はない。

 

ソース

転載OKの.scより

Kona Linux 2杯目

http://maguro.2ch.sc/test/read.cgi/linux/1446805401/738,808,821

 

あと使った所は、いつもの
Linux Packages Search
http://pkgs.org/  

 

RPM Search    <ーー今回はこれは使用せず。
http://rpm.pbone.net/